Degraded Performance

Incident Report for Aeries Software

Resolved

This incident has been resolved.
Posted May 28, 2025 - 07:48 PDT

Update

We are continuing to work on a fix for this issue.
Posted May 27, 2025 - 12:51 PDT

Identified

The issue has been identified and will be addressed during a maintenance window tonight. Performance has improved and is expected to remain operational for the rest of the business day.
Posted May 27, 2025 - 10:35 PDT

Investigating

We are currently experiencing degraded performance. Our engineers are currently investigating.
Posted May 27, 2025 - 09:45 PDT
This incident affected: Aeries Cloud Services (AWS CA).