A release has been scheduled for deployment to address the performance issues with reporting services.
Posted Jul 22, 2026 - 18:16 PDT
Update
The changes are still being tested. They are currently scheduled to be released and deployed tonight.
Posted Jul 22, 2026 - 14:57 PDT
Identified
We are reverting the status to "Identified" as it has been determined that the issue requires engineering changes to fully resolve. Our operations team is monitoring reporting capacity until a fix is released and deployed.
Posted Jul 22, 2026 - 13:01 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 22, 2026 - 09:28 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 22, 2026 - 09:17 PDT
Investigating
We are currently investigating this issue.
Posted Jul 22, 2026 - 09:14 PDT
This incident affected: Aeries Cloud Services (AWS CA).